Gene6 FTP Server Forum: solution to error 500 unknown command - Gene6 FTP Server Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

solution to error 500 unknown command Rate Topic: -----

#1 User is offline   alkahtane 

  • New Member
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 12-March 07

Posted 12 March 2007 - 07:44 AM

500 unknown command

The solution to this problem

This error message is mainly caused by a fire wall

Example

In Microsoft frontpage , publishing an audio or video file sometimes causes a malfunction with the frontpage file extensions , preventing publishing any files onto a server

A user may reinstall the extensions , only to get the same error message " 500 unknown command " again

details on fixing this problems are displayed step by step at

http://alkahtane.com/500%20unknown%20command.htm


good luck

follow the instructions
and , your Error 500 unknown command nightmare is over

www.alkahtane.com
The truth for a change,
about the end of time and much more

This post has been edited by alkahtane: 12 March 2007 - 07:45 AM

0

#2 User is offline   EJocys 

  • New Member
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 11-December 04

Posted 06 July 2007 - 10:31 PM

SYMPTOMS

FTP server returns "500 unknown command" for existing commands.

CAUSE

Windows Data Execution Prevention (DEP) is enabled for all programs and services including G6FTPServer service.

RESOLUTION

You need to exclude G6FTPServer.exe from Data Execution Prevention:
  1. Click [Start] button -> Control Panel -> System. ("System Properties" window will open)
  2. Select [Advanced] tab -> Click "Performance" [Settings] button. ("Performance Options" window will open)
  3. Select [Data Execution Prevention] tab -> [Add...] button.
  4. Browse to: C:\Program Files\Gene6 FTP Server\G6FTPServer.exe, click [Open]
  5. Click [Ok] button, click [Ok] button.
  6. Restart "G6FTPServer".
Keywords: STOR, upload, problems

This post has been edited by EJocys: 06 July 2007 - 10:59 PM

0

#3 User is offline   EJocys 

  • New Member
  • Pip
  • Group: Members
  • Posts: 6
  • Joined: 11-December 04

Posted 24 July 2007 - 05:27 PM

ADVICE 2

Sometimes just simple restart of Gene6 FTP Service helps to solve all problems:
  1. [Start] -> Run...
  2. Enter: cmd /C net stop G6FTPServer && net start g6FTPServer
  3. Click [OK] button.
ADVICE 3

If transfer still hangs then you can try to configure passive ports range.
  1. Open "Gene6 Server Administrator"
  2. Select: G6FTP Server \ Local Machine \ Domain \ ftp.domain.com
  3. Right-mouse click and choose Properties
  4. Select: Secure \ IP Binding
  5. On right side specify "Passive Port Range" from 5500 to 5700
  6. Click [OK] button
If you have Windows Firewall turned ON then:
  1. [Start] -> Control Panel -> Windows Firewall
  2. Select [Exceptions] tab
  3. Click [Add Program...]
  4. Browse to: C:\Program Files\Gene6 FTP Server\G6FTPServer.exe, click [Open]
  5. Click [Ok] button, click [Ok] button
...as alternative you can:

Add ports range to Firewall:
  1. [Start] -> Run...
  2. Enter: cmd /C FOR /L %I IN (5500,1,5700) DO netsh firewall add portopening TCP %I "FTP Server - Passive Range (TCP %I)" ENABLE ALL
  3. Click [OK] button
Delete ports range from Firewall:
  1. [Start] -> Run...
  2. Enter: cmd /C FOR /L %I IN (5500,1,5700) DO netsh firewall delete portopening TCP %I ALL
  3. Click [OK] button

Note 1: If you are behind firewall then make sure that you are forwarding ports 5500-5700 to FTP Server.
Note 2: You can create Service_FTP.bat file to configure windows firewall automatically:
CODE
::@echo off
SET mode=%1
IF "%1" == "" SET mode=ENABLE
SET nth=netsh firewall add portopening
::
%nth% TCP  20 "FTP Server - Data (TCP 20)"         %mode% ALL
%nth% UDP  20 "FTP Server - Data (UDP 20)"         %mode% ALL
%nth% TCP  21 "FTP Server - Control (TCP 21)"      %mode% ALL
%nth% UDP  21 "FTP Server - Control (UDP 21)"      %mode% ALL
%nth% TCP 989 "FTP Server - SSL Data (TCP 989)"    %mode% ALL
%nth% UDP 989 "FTP Server - SSL Data (UDP 989)"    %mode% ALL
%nth% TCP 990 "FTP Server - SSL Control (TCP 990)" %mode% ALL
%nth% UDP 990 "FTP Server - SSL Control (UDP 990)" %mode% ALL
:: Open default range of ports for passive transfers:
FOR /L %%I IN (5500,1,5700) DO (
    %nth% TCP %%I "FTP Server - Passive Range (TCP %%I)" %mode% ALL
)
pause

This post has been edited by EJocys: 24 July 2007 - 05:29 PM

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users