Gene6 FTP Server Forum: SSL not working - Gene6 FTP Server Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

SSL not working Rate Topic: -----

#1 User is offline   cmhxaktsoft 

  • New Member
  • Group: Registered Users
  • Posts: 5
  • Joined: 23-February 07

Posted 13 April 2007 - 04:50 PM

Hello,
I have Gene6FTP 3.9.0 (Build 2) installed. I am trying to connect, and I get this:

07/04/13 11:38:36, 0, 172.22.2.42, , new connection from 172.22.2.42 on 172.22.2.77:21 (Explicit SSL)
07/04/13 11:38:37, 0, 172.22.2.42, , hostname resolved : XXXXXXXX
07/04/13 11:38:37, 0, 172.22.2.42, , sending welcome message.
07/04/13 11:38:37, 0, 172.22.2.42, , 220 Private FTP Server. This server is intended for authorized access only.
07/04/13 11:38:37, 0, 172.22.2.42, , AUTH TLS
07/04/13 11:38:37, 0, 172.22.2.42, , 234 AUTH command ok; starting SSL connection.
07/04/13 11:38:37, 0, 172.22.2.42, , 431 Could not establish secure connection.
07/04/13 11:38:37, 0, 172.22.2.42, , disconnected. (00d00:00:00)

I am using FileZilla, but I tried SmartFTP and am getting the same message. Also, I get the same message if I try to connect to localhost from the actual server.

07/04/13 11:47:23, 2, 127.0.0.1, , new connection from 127.0.0.1 on 127.0.0.1:21 (Explicit SSL)
07/04/13 11:47:23, 2, 127.0.0.1, , hostname resolved : XXXXXXXX
07/04/13 11:47:23, 2, 127.0.0.1, , sending welcome message.
07/04/13 11:47:23, 2, 127.0.0.1, , 220 Private FTP Server. This server is intended for authorized access only.
07/04/13 11:47:23, 2, 127.0.0.1, , AUTH TLS
07/04/13 11:47:23, 2, 127.0.0.1, , 234 AUTH command ok; starting SSL connection.
07/04/13 11:47:23, 2, 127.0.0.1, , 431 Could not establish secure connection.
07/04/13 11:47:29, 2, 127.0.0.1, , disconnected. (00d00:00:05)

In the past, I messed around with trying to install a commercial certificate, but that wasn't working well, so I switched to a self-signed one. They have the same name, which I fear might be causing the problem, but I can't see a way around this, as the certificate name needs to match the domain. I went into the certificate manager on the server and removed all references to the original certificate, but that did not help. I deleted all files in the "certificates" folder, and re-created a new one from scratch. I cleared out the Cert&Key files from the SSL tab, and deleted and re-created my IP bindings in Server Properties. I am at a loss. This is a production server, and it is unreachable in its current state. Any help is greatly appreciated. Thanks!
0

#2 User is offline   cmhxaktsoft 

  • New Member
  • Group: Registered Users
  • Posts: 5
  • Joined: 23-February 07

Posted 13 April 2007 - 04:57 PM

OK, I think I found the problem. When I was messing with the commercial cert, I added the following line to the settings.ini file:

SSLPassPhrase=xxxxxxxx

Once I removed that line, it seems OK again. Just leaving this post for posterity, in case any other people do something boneheaded like this. smile.gif
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users